不支持Flash

手把手教你在Linux上运行IE浏览器

http://www.sina.com.cn 2007年11月01日 15:37  IT168.com

  饮水思源 编译

  对于在Linux上安装微软的产品,尤其是IE浏览器,大多数Linux用户会感到比较惊恐,唯恐其污染了纯洁的Linux。但是,在使用普通的Linux下的浏览器浏览网页的时候,例如Firefox或Konqueror等,很多网站不能正常显示。这些网站或者需要ActiveX控件的支持,或者在设计的时候只考虑到支持IE浏览器。还有,即使你是一个Apache和Linux专家,你怎么来测试你的新网站设计和JavaScript是否在IE下运行良好呢?

  对于那些对IE浏览器有需求的朋友,而又不想换到另一台计算机或对计算机进行重启的话,有一种解决方案可以选择:一个叫做IEs4Linux的非常有用的项目。在本篇文章中,我将介绍如何使用Wine和IEs4Linux来安装和开始使用多版本的IE浏览器。

  了解IEs4Linux

  IEs4Linux是一小段命令行脚本程序,它可以通过终端运行在安装了Wine的任何Linux计算机上。正如本文题目所说的,它可以让你简单、迅速的安装那个最著名的微软产品之一:IE浏览器。

  IEs4Linux的创建者是Sérgio Luís Lopes Júnior,一个21岁的巴西学生,自称是Linux和开源软件爱好者。作为开源软件,很自然IEs4Linux是免费的。但是,和来自开源项目的许多人一样,Sérgio的资金来自于社区;如果你发现IE4Linux对你有帮助的话,你可以捐赠给他几美元以继续推动这个项目的开发。

  IEs4Linux依靠Wine项目来提供微软的Windows应用程序编程接口(API)的实现。IEs4Linux的脚本实际上是直接从微软的站点下载所需的CAB文件;然后,使用cabextract拷贝这些文件到一个新的Wine配置。通过这种方式,你已有的Wine配置不会被影响,而且你已经运行的任何其他软件将会依然正常运行,除了可以支持安装IE 5、IE 5.5和IE 6外,IEs4Linux还能够为你安装来自Adobe的Flash 9。

  IEs4Linux是一个GPL产品;但是,IE浏览器是一个微软的版权产品。这意味着你需要拥有一个合法的Windows 95之后的授权许可,当然在这个安装过程中并不要求你提供这个许可。

  作者注:

  在本篇文章中,我将假定你已经运行了最近的Ubuntu作为你的Linux版本。IEs4Linux几乎可以支持所有的版本,但是安装的过程可能会有所不同。本文将假定你已经安装并在使用Ubuntu桌面版。

  根据人们安装软件方式的喜好,本文中我介绍了两种安装过程,首先是图形化界面的方法,然后是终端(命令行)方法。

 [1] [2] [3] [4] [下一页]

发表评论 _COUNT_条
爱问(iAsk.com)
不支持Flash
·城市营销百家谈>> ·城市发现之旅有奖活动 ·企业邮箱换新颜 ·邮箱大奖等你拿
不支持Flash
不支持Flash