不支持Flash

Apache HTTP Server Mod_Cache模块漏洞

http://www.sina.com.cn 2007年10月08日 11:06  中关村在线
作者:中关村在线 张齐

受影响系统:
Apache Group Apache 2.2.x
Apache Group Apache 2.0.x
Apache Group Apache 1.3.x

不受影响系统:
Apache Group Apache 2.2.6
Apache Group Apache 2.0.61
Apache Group Apache 1.3.39

描述:

BUGTRAQ  ID: 24649
CVE(CAN) ID: CVE-2007-1863

Apache HTTP Server是一款流行的Web服务器。

Apache HTTP Server(httpd)的mod_cache模块中的cache_util.c文件存在安全漏洞,远程攻击者可能利用此漏洞导致服务器崩溃。

如果服务器启用了缓存且在使用线程多处理模块(MPM),远程攻击者就可以通过发送特制的HTTP请求且不对s-maxage、max-age、min-fresh或max-stale Cache-Control头设置值导致子进程处理器崩溃。

厂商补丁:

Apache Group

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://httpd.apache.org/download.cgi

RedHat

RedHat已经为此发布了安全公告(RHSA-2007:0557-01、RHSA-2007:0533-01、RHSA-2007:0556-01、RHSA-2007:0534-01)以及相应补丁:
RHSA-2007:0557-01:Moderate: httpd security update
链接:https://www.redhat.com/support/errata/RHSA-2007-0557.html

RHSA-2007:0533-01:Moderate: httpd security update
链接:https://www.redhat.com/support/errata/RHSA-2007-0533.html

RHSA-2007:0556-01:Moderate: httpd security update
链接:https://www.redhat.com/support/errata/RHSA-2007-0556.html

RHSA-2007:0534-01:Moderate: httpd security update
链接:https://www.redhat.com/support/errata/RHSA-2007-0534.html

爱问(iAsk.com)
不支持Flash
·城市营销百家谈>> ·城市发现之旅有奖活动 ·企业管理利器 ·新浪邮箱畅通无阻
不支持Flash